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LabVIEW
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LabVIEW okruženje



Koncept virtuelnog instrumenta

• Uvod u LabVIEW okruženje. 
• Osnovni elementi okruženja – front panel, blok dijagram, toolbar, help i 

interaktivni help.
• Koncept data-flow programiranja.
• Matematičke operacije, relacije.
• Logičke operacije.
• Funkcije, konstante, kontrole i indikatori.



5

Virtuelni instruneti (VI)

Front Panel – interfejs 
instrumenta
• Kontrole = ulazi
• Indikatori= izlazi

Blok dijagram
• Programski kod asociran

front panelu
• Komponente povezane 

međusobno – data flow 
programiranje

Presenter
Presentation Notes
LabVIEW programs are called virtual instruments (VIs).

Stress that controls equal inputs, indicators equal outputs.

Each VI contains three main parts:
    Front Panel – How the user interacts with the VI.
Block Diagram – The code that controls the program.
Icon/Connector – Means of connecting a VI to other VIs.
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LabVIEW dijalog

Presenter
Presentation Notes
This slide shows the startup screen for LabVIEW 7.0
The LabVIEW dialog box includes the following components:
A menu bar with standard items such as File»Exit.
A set of buttons for creating and opening VIs, configuring DAQ devices, and finding helpful information.
Click the New button to create a new VI. Click the arrow on the New button to choose to open a blank VI or to open the New dialog box.
Click the Open button to open an existing VI. Click the arrow on the Open button to open recent files.
Click the Configure button to configure your DAQ devices. Click the arrow next on the Configure button to configure LabVIEW.
Click the Help button to launch LabVIEW Help. Click the arrow on the Help button for other Help options, including the Example Finder.
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Kreiranje novog instrumenta

• File»New VI kreira novi VI

• File»New… otvara dijalog za kreiranje VI prema templejtu, 
projekta, itd.

Presenter
Presentation Notes
Click the New button to create a new VI.  Click the arrow on the New button to choose to open a blank VI or to open the New dialog box.
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Template Browser

Presenter
Presentation Notes
When you click the New button, the New dialog box appears. You also can select File»New to display this dialog box. Select a template in the Create new listbox to display the front panel in the Front Panel Preview section, to display the block diagram in the Block Diagram Preview section, and to display a description of the template in the Description section.
Select a template and click the OK button to start building a VI or other LabVIEW document. Press the <Ctrl-N> keys to bypass this dialog box and create a new empty VI.
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Meni

Presenter
Presentation Notes
The menus at the top of a VI window contain items common to other applications, such as Open, Save, Copy, and Paste, and other items specific to LabVIEW. Some menu items also list shortcut key combinations.
Some menu items are unavailable while a VI is in run mode.
The File menu contains items used for basic file operations, such as opening, closing, saving, and printing files.
The Edit menu contains items that allow you to search for and modify LabVIEW files and their components.
The Operate menu contains items you use to control the operation of your VIs.
The Tools menu contains items for configuring LabVIEW, your projects, and your VIs.
The Browse menu contains items that allow you to view aspects of the current VI and its hierarchy.
The Window menu contains items that allow you to configure the appearance of the current windows and palettes. You also can access the Error List window and view the contents of the clipboard.
The Help menu contains items to explaining and define LabVIEW features and other components, provide full LabVIEW documentation, and access National Instruments technical support.
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Front Panel prozor

Front panel
paleta

Graph
legenda

Logička
kontrola

Waveform
grafik

ikona

Plot
legenda

Scale
legenda

Waveform
Graph
labela

Presenter
Presentation Notes
This slide represents the front panel of a typical VI.

Point out the elements in the Panel window:
   Panel Toolbar: contains tools and command buttons used to control the VI.
Discuss the controls, indicators, and labels.



11

Blok dijagram prozor

Veza

Graph
indikator

SubVI

While Loop
struktura

Blok 
dijagram
paleta Funkcija

deljenja

numerička
konstanta

Timing 
funkcija

Logička kontrola

Presenter
Presentation Notes
This slide shows the block diagram for the front panel on the last slide.

Point out front panel object terminals, constants, and nodes. (Note the Wait Until Next ms Multiple function, Divide function, subVI, and wires.)

Reinforce front panel object-terminal relationship.
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Front panel i Blok dijagram paleta

Run dugme
Continuous Run dugme
Abort dugme
Pause/Continue dugme

• Execution Highlighting dugme
• Step Into dugme
• Step Over dugme
• Step Out dugme

Warning indikator

Enter dugme

Broken Run dugme

Font prsten
Alignment prsten
Distribution prsten
Resize prsten
Reorder prsten
Context Help dugmeDodatne komande na Blok 

dijagram paleti

Presenter
Presentation Notes
Launch LabVIEW and discuss the buttons using the computer; never use the abort button or continuous run button when doing demonstrations.  Set a good example!

Tools used to create, modify, debug, and execute VIs:

Panel Toolbar: Located in the Panel window.
Broken Run: Click on it to find errors.
Continuous Run: Use for testing sections of code. Should use a while/for loop for repeating parts of a diagram in an application. 
Stop: Not a clean way to terminate the program. Avoid using it. Use a switch on the panel.

Diagram Toolbar: Additional tools to debug the VI.
Briefly explain each button. Tell the class we will discuss them in more detail when we talk about debugging. 

When running a VI, the font, alignment, and distribution rings disappear because they are editing tools.



13

Tools paleta

• LabVIEW automatski selektuje alat 

• Dostupna je na blok dijagramu i front panelu

• Alat je specijalni mod kursora

• Koristi se za izmenu i manipulisanje objektima na front 
panelu i blok dijagramu

• Paleta je dostupna izborom iz menija
VIEW » Tools Palette

Presenter
Presentation Notes
Graphical, floating palettes. Tools can be used for editing, debugging, and operating VIs.
You can hide/show palettes by enabling or disabling them via the Window menu.
Shortcut key (shift-right click - Windows)
Although most will use the automatic tool selection, it is important that user understand the difference between the different tools so that they know when to use it.  For example, when hovering over a boolean control, you may have the labeling tool, the selection tool or the operating tool depending on where the mouse cursor is.  How do you know when to click?
Demonstrate!

Be sure to know all the correct names for the tools in the palette and take your time familiarizing students with their names.  In particular, stress the difference between the Position/Resizing Tool and the Operator as students will often have the wrong tool and if you can vocally instruct them to get the correct tool it causes much less frustration.
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Front panel − paleta sa kontrolama

Paleta sa kontrolama
Najčešće korišćene kontrole

Sve kontrole 
grupisane prema 
stilovima i funkciji

Presenter
Presentation Notes
Graphical, floating palettes.
You can access the Controls palette only from the Panel window.
If palettes are not displayed, you can access them via the Window menu and select the Show Controls palette.
OR, right click on open area of front panel or diagram window to display Controls palette.




Blok dijagram − paleta sa funkcijama

Paleta Functions/Express
Sadrži Express VI (interaktivni VI 
sa konfigurabilnim dijalogom) i 

često korišćene funkcije i 
programske strukture

Paleta sa svim funkcijama
Prikazane su sve raspoložive 
funkcije i programske strukture
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Presenter
Presentation Notes
Graphical, floating palettes.
You can access the Functions palette only from the Block Diagram window.
If palettes are not displayed, you can access them via the Window menu and select the Show Functions palette.
OR, right click on open area of front panel or diagram window to display Functions palette.
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Palete

• Paleta može biti fiksirana ili plivajuća
• Subpalete se mogu posebno izdvojiti
• Customize opcija omogućava 

podešavanje prikaza

Traženje Opcije

Klikom na čiodu se fiksira paleta

Paleta više 
u hijerarhiji

Presenter
Presentation Notes
Graphical, floating palettes.
If palettes are not displayed, you can access them via the Window menu and select the Show Functions/Controls palette.
OR, right click on open area of panel or diagram window to display Controls and Functions palettes, respectively.
Click on subpalettes to access functions, controls, VIs. You can tack down palettes and subpalettes using the pushpin. 
Tack down by clicking on the pushpin on the top left corner of the palette.
Once tacked down you can set the palette options and use the find tool.
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Pretraga kontrola, VI, i funkcija

• Klikom na Search dugme 
omogućena je pretraga 
kontrola i funkcija

• Prevlačenjem na 
dijagram/panel selektuje 
se željena 
funkcija/kontrola, 
dvostrukim klikom na 
funkciju/kontrolu otvara 
pripadajuća paleta

Presenter
Presentation Notes
Use the buttons on top of the palette windows to navigate, search, and edit the palettes.

You can search for controls, VIs, and functions that either contain certain words or start with certain words. Double clicking a search result opens the palette that contains the search result. You also can click and drag the name of the control, VI, or function directly to the front panel or block diagram.
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Front panel sadrži kontrole (ulazi) i
indikatore (izlazi) – predstavlja korisnički interfejs

Numerička
kontrola

Numerički 
indikator

Labele

Logička
kontrola

Logički
indikator

Kreiranje  Front panela

Inkrementator

Presenter
Presentation Notes
Creating the front panel (user interface):

Built with controls and indicators:
Controls: Supply data to the VI.
Indicators: Display data generated by the VI.
They can find out if it is a control or indicator by checking the right-click menu of the object and referring to the third item (Change to Indicator or Change to Control)
Explain graphics on slide:
Numeric controls: Point out increment buttons.
Numeric indicators: No increment buttons.
Boolean objects: Ask class which Boolean is a control and which is an indicator.  Explain that even though an LED is an indicator in the real world, it can be changed to a control in LabVIEW.  Demonstrate.
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Kontekstni meniji za objekte front panela

Desni klik na labelu otvara 
kontekstni meni

Desni klik na indikator otvara 
kontekstni meni

Presenter
Presentation Notes
Right-click menus: Most often used LabVIEW menus.

Most LabVIEW objects have these menus for modification of attributes pertaining to that object.
Functions/Controls palettes are available as right-click menus.
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Properties dijalog

Izborom opcije 
Properties iz 
kontekstnog menija 
otvara se dijalog sa 
opcijama objekta koji 
je selektovan

Presenter
Presentation Notes
Explain the options available for the numeric control, as shown on the slide.

Also explain that property pages will differ dependant on the object selected.
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čvoroviveze

Terminali
kontrola

Blok dijagramFront Panel
Terminali
indikatora

Kreiranje Blok dijagrama

Presenter
Presentation Notes
The block diagram is the “code” for the VI. 

Note: Wires can cross each other. You will see dots at the wire junctions, and a small gap in the wire showing that wires do not connect. If dots at wire junctions have been turned off, go to Options (Tools menu)»Block Diagram and select Show dots at wire junctions.

Point out border difference and arrow direction on controls and indicator terminals.

Composed of nodes, terminals, and wires:

Nodes: Program execution elements (analogous to statements, functions, and subroutines).

Functions: Built-in nodes for elementary functions.
SubVIs: VIs you design and later call from the diagram of another VI.
Structures: Control the program flow.



Tipovi čvorova

• Indikatori, konstante i kontrole

• Funkcije

• Virtuelni instrumenti

• Strukture

22
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Express VI, VI i funkcije

• Express VI: interaktivni VI sa dijalogom za podešavanje
• Standardni VI: modularni VI koji se mogu modifikovati povezivanjem
• Funkcije: fundamentalni elementi u LabVIEW okruženju, kojima ne 

korespondiraju front paneli ni blok dijagram



24

VI

Ikona

• Basic Function Generator VI (primer)
• Isti VI, predstavljen u tri različita 

oblika
• Žuta oblast oko ikone označava 

standardni VI
• Plava oblast oko ikone označava 

Express VI

Čvor Razvučeni čvor

Presenter
Presentation Notes
Note that you can have all functions be placed as expandable nodes by enabling an option in the Tools >> Options >> New to LabVIEW 7.0 menu.  You can change from an expandable function/node to an icon view, but if the option is not enabled you cannot change from the icon view to the expandable node.
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Terminali

• Terminali su ulazne i izlazne 
tačke čija je funkcija razmena 
podataka između blok 
dijagram i front panela

• Terminali su analogni 
ulazno/izlaznim parametrima 
i konstantama u klasičnim 
programskim jezicima

• Desnim klikom na terminal 
moguće je podesiti njegov 
izgled
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Povezivanje elemenata u blok dijagramu

Skalar

Numerički

Logički

String

2D niz1D niz

Dinamički

Presenter
Presentation Notes
Not a complete list of data types; just ones that are used frequently through this course.
Explain that in LabVIEW, you use wires to connect multiple terminals together to pass data in a VI. The wires must be connected to inputs and outputs that are compatible with the data that is transferred with the wire, therefore understanding the different data types is key to correct wiring.
Explain the difference in colors and thicknesses.
Explain that arrays and strings will be covered later in the course.
Also, dynamic data type does not change width based on contents.


Students are often looking for a more detailed list of all the data types in LabVIEW.  If they ask about that, point them to the Help >> VI, Function, & How-To Help…  On the Index Tab, search for data types and double click on the keyword to get a display on all of the data types and terminal representations in LabVIEW. 
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Tehnike povezivanja

Hot Spot• Automatsko povezivanje
• Context Help Window može 

biti koristan
• Desni klik na vezu otvara 

kontekstni meni 
• Tip labele
• Automatsko rutiranje
• Za preciznije povezivanje 

selektovati Visible 
Items »Terminals

Označiti terminale funkcije

Presenter
Presentation Notes
Demonstrate wiring by placing two controls, one indicator, and an Add function.
Use the Help window (point out how terminals in the Help window flash when the tool passes over the actual function terminal).
right-click on the Add function and select Show Terminals.
Point out Tip Strips.



If students really struggle with wiring, remember that they can enable the Terminal view and that can help.  If that is still not enough, they can enable the option to have nodes placed as expandable.  That won’t fix all problems, and the last option is to reduce the monitor resolution to something like 800x600.
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• Funkcije u blok dijagramu 
se izvršavaju zavisno od 
toka podataka; blok 
dijagram se ne izvršava s 
leva na desno

• Funkcija se izvršava kada 
su dostupni svi podaci na 
ulaznim terminalima

• Funkcije postavljaju 
rezultate na izlaznim 
terminalima nakon izvršenja

Dataflow programiranje

Presenter
Presentation Notes
Most text based programs execute in an control flow model.

Dataflow is the principle that governs how LabVIEW programs execute.

Explain the diagram on this slide with emphasis on dataflow.

The node executes when data is available at all of its input terminals.
The node supplies data on output terminals when it finishes execution.
Not executed left to right nor top to bottom.

Test understanding by asking class what will happen first when this program runs.  Then, build the above diagram on your computer and demonstrate the dataflow using execution highlighting.

It is helpful to start out by asking the class what they think will happen first on this block diagram.  You will get answers from Number 1-4, random number, etc., but eventually someone will say that there is no way to know.  Then, show will execution highlighting.
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Kontekstni Help

• Da bi se prikazao kontekstni Help prozor selektovati
Help » Show Context Help, pritisnuti <Ctrl-H> tastere, ili 
aktivirati Show Context Help Window dugme na paleti 
sa alatima

• Help je prikazan za
objekt ispod kursora

• Veze:
Obavezne – bold
preporučene – normal
Opcione – dimmed

Simple/Detailed Context Help       Zaključan Help      Detaljan Help

Presenter
Presentation Notes
If required is unwired, receive error when running program.
If recommended is unwired, receive warning when running program.
If optional is unwired, no effect when running program.



Give examples!  The more examples of how you have used things to solve customer problems, the more they will trust you.  Something that every LabVIEW supporter uses is Context Help.  Explain how we cannot all be responsible for knowing what every function or VI does and we do not expect that of them, either, but that Context Help is our encyclopedia for VIs and functions.  This is also a good place to begin getting them to think about good documentation practices of their own VIs so that users of their programs can get the same help.
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LabVIEW Help

• Aktiviranjem More Help dugmeta na Context Help
prozoru

• Selektovanjem Help»LabVIEW HELP

Help sadrži detaljne opise većine paleta, menija, alata, 
VI, funkcija, instrukcija za korišćenje LabVIEW opcija, 
linkove ka online resursima, tutorijalima, PDF verzijama 
priručnika i tehničkoj podršci.

Presenter
Presentation Notes
Use an example program to demonstrate the help tools.

Suggestion: Open help and search the index using ‘menus’. You can then show the class where they can find information on the menu items discusses in the earlier slide.
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NI Example Finder

• Za pronalaženje primera, 
izabrati Help » Find 
Examples

• Web-integrisan
• Pretraga po ključnoj reči, 

tipu primera, tipu 
hardvera i slično

Presenter
Presentation Notes
Use the buttons on top of the palette windows to navigate, search, and edit the palettes.

You can search for controls, VIs, and functions that either contain certain words or start with certain words. Double clicking a search result opens the palette that contains the search result. You also can click and drag the name of the control, VI, or function directly to the front panel or block diagram.
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Debagovanje

Pronalaženje grešaka
Klikom na Broken Run dugme otvara se prozor sa 
objašnjenjem greške.

Naglašavanje izvršenja
Klikom na Execution Highlighting dugme, tok podataka
je animiran. Vrednosti podataka su prikazane na vezama.

Presenter
Presentation Notes
When your VI is not executable, a broken arrow is displayed in the Run button in the palette.
Execution Highlighting: Animates the diagram and traces the flow of the data, allowing you to view intermediate values.  Click on the light bulb on the toolbar.	
Finding Errors: To list errors, click on the broken arrow. To locate the bad object, click on the error message.
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Debagovanje

Sonda (Probe)
Desnim klikom na vezu i izborom 
Probe, otvoriće se prozor sa prikazom 
podatka na vezi

Prekidi (Brakpoints)
Desnim klikom na vezu i izborom 
Breakpoint/Set Breakpoint izvršenje 
će biti zaustavljeno na tački prekida

Uslovna sonda (Conditional Probe)
Kombinacija sonde i prekida. Desnim 
klikom na vezu i izborom Custom
probe/Conditional Double Probe.
Izvršenje će biti prekinuto ukoliko je 
ispunjen uslov.

Presenter
Presentation Notes
Probe: Used to view values in arrays and clusters.  Click on wires with the Probe tool or right-click on the wire to set probes.
Create a probe when you want to have more control over how LabVIEW probes the data that flow through a wire. When you create a new probe, the data type of the probe matches the data type of the wire you right-click.  Custom probes are also available - show if time permits.

Breakpoint: Set pauses at different locations on the diagram.  Click on wires or objects with the Breakpoint tool to set breakpoints.

Conditional probe: a probe on which conditions can be set for when to break at the probe.



It is VERY easy to place additional breakpoints on a VI.  Teach students that if their program is not running correctly and they think they may have a breakpoint…somewhere…that they can use the Edit >> Find, Other – Breakpoints search tool to locate all breakpoints placed on their block diagrams!
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Step Into, Over, and Out kontrola izvršavanja (Single 
Stepping)

Izborom Step Into pokreće se single 
stepping.
Kada Single Stepping počne, kontrola se 
prenosi sledećoj funkciji

Izborom Step Over preskače se sledeći čvor

Izborom Step Out preskaču se čvorovi do 
kraja izvršenja

Debagovanje

Presenter
Presentation Notes
Single stepping: executes the diagram node by node.
You can access single stepping from the diagram toolbar by using the step functions found on the diagram toolbar.

Use Step Into/Step Over to begin single stepping.

Step Into: Steps into a node. If there is a subVI, it will then bring up the subVI diagram and enable single stepping through it.

Step Over: Executes nodes but visually does not single step through nodes.

Step Out: Steps out of nodes, if the diagram has completed execution; click on Step Out to terminate single stepping mode.
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Neke napomene za efikasniji rad

• Prečice sa tastature

• Pristup Tools paleti sa <shift>-desni-klik
• Povećaj/umanji brže pomoću <shift> tastera
• Tools»Options – podešavanje LabVIEW okruženja
• VI Properties (File meni) – podešavanja VI

Windows      Sun        Linux       MacOS
<Ctrl-R> <♦-R> <M-R> <-R> pokreće VI
<Ctrl-F> <♦-F> <M-F> <-F> traži objekt
<Ctrl-H> <♦-H> <M-H> <-H> aktivira Context Help prozor
<Ctrl-B> <♦-B> <M-B> <-B> Uklanja sve nepovezane veze
<Ctrl-W> <♦-W> <M-W> <-W> Zatvara aktivan prozor
<Ctrl-E> <♦-E> <M-E> <-E> Menja fokus Diagram/Panel prozor

Presenter
Presentation Notes
Demonstrate these techniques so that students can practice them throughout the course.

Highlight the following tips:
Hot keys (ctrl -b, ctrl-e, etc.)
Accessing functions and controls palettes by right-clicking
Accessing tools palette temporarily by shift - right-click (Windows) or shift - command - click (Mac)
Tab to toggle through toolbars
Spacebar to toggle between positioning and operating tool (panel toolbar)
Spacebar to toggle between positioning and wiring tools (diagram toolbar)
Wiring: spacebar to change direction
Wiring: click with right mouse click to terminate wiring once started
Undo and Redo in the Edit menu

1st Day Lunch
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• Virtuelni instrumenti (VI) imaju tri osnovna dela – front panel, 
blok dijagram, ikonu sa konektorskim terminalima

• Front panel je korisnički iterfejs LabVIEW programa, blok 
dijagram predstavlja izvršni kôd programa

• Blok dijagram sadrži grafički izvorni kôd sačinjen od čvorova, 
terminala i veza

• Express VI, standardni VI i funkcije služe za kreiranje 
grafičkog kôda. Korišćenje Express VI sa konfigurabilnim 
dijalogom daje najbrže rezultate

• Palete: Tools paleta, Controls paleta (dostupna kada je prozor 
Front panela aktivan), i Functions paleta (dostupna kada je 
prozor Blok dijagrama aktivan)

• Na raspolaganju su Context Help Window i LabVIEW Help

Pregled

Presenter
Presentation Notes
Do not immediately display this slide.

 Suggested questions for class participation:
 What are the two main windows in the LabVIEW environment?
 What do the Panel and Diagram Toolbars contain?
 What are the differences between controls and functions? Where are each located?
 What are the three palettes in the LabVIEW environment?
 What are pop-up menus? How are they used?
 How do you get help?

 Review slide: The purpose of Lesson One was to introduce the�  LabVIEW environment and some simple VI concepts, LV help, and debugging techniques.

 When in doubt, right click!!
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Pregled

• Kontrole (ulazi) i indikatori (izlazi) se rapoređuju na Front panel 
prozoru

• Operating tool služi za manipulisanje objektima na panelu. 
Positioning tool služi za selekciju, pomeranje i promenu veličine 
objekata. Wiring tool služi za povezivanje objekata na blok 
dijagramu.

• Kontrole imaju  deblju ivicu od indikatora
• Svi front panel objekti imaju property strane i kontekstni meni
• Povezivanje je proces za kontrolu toka podataka i programiranje 

LabVIEW programa
• Broken Run strelica signalizira grešku u programu
• Različiti alati za debagovanje su na raspolaganju: sonde, prekidi, 

naglašavanje izvršenja, izvršavanje korak po korak

Presenter
Presentation Notes
See the tips and tricks and the end of the chapter to practice.



Vežba 1 – Konvertovanje 
temperature iz °C to °F

Presenter
Presentation Notes
Estimate completion time: 20 minutes. The exercise is easy, but since it will be the first VI that we actually create, it is good to allow ample time to explore the LabVIEW environment.

Build a VI that converts °C to °F. When run, the VI should take an input value (°C), multiply it by 1.8, add 32, and display the result (°F). The front panel should display both the input value and the result. Save the VI as Convert C to F.vi.




Konverzija temperature

• Realizujte VI koji konvertuje °C u °F.
• Kada se pokrene VI uzima ulazne podatke sa kontrole Temperatura u 

(°C), množi sa 1.8, dodaje 32, i prikazuje rezultat temperatura u (°F).
• Front panel treba da prikazuje obe temperature
• Snimite VI kao Convert C to F.vi.



Vežba 2 – Jednostavan 
kalkulator



Kalkulator

• Realizujte VI koji ima funkciju jednostavnog kalkulatora
• VI uzima vrednosti dva operanda sa kontorle na front panelu i prikazuje 

rezultate sabiranja, oduzimanja, množenja i deljenja
• Vrednosti operanada i rezultata se prikazuju na front panelu
• Snimiti VI kao kalkulator.vi
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